lots of relaylock & authpsa processes + mail failure

Since I updated to plesk 9.2 I have problems with receiving mail after a few hours. When i check my system for active processes using “top” I receive a ton of entries like:
http://forum.parallels.com/showthread.php?t=92832

Quote:
2464 root 19 0 18600 1092 924 R 24 0.1 11:35.03 relaylock
20598 root 18 0 18600 1092 924 R 22 0.1 1:16.58 relaylock
27919 root 19 0 18596 1088 924 R 20 0.1 0:15.60 relaylock
18671 root 18 0 18596 1088 924 D 20 0.1 1:26.57 relaylock
26431 root 18 0 18600 1092 924 R 18 0.1 0:23.79 relaylock
32555 root 18 0 20196 1488 1216 R 16 0.1 20:13.07 authpsa
3198 root 18 0 20196 1488 1212 D 6 0.1 10:28.25 authpsa
3551 root 18 0 20196 1492 1212 R 6 0.1 9:30.23 authpsa
11648 root 19 0 18600 1096 924 R 6 0.1 3:30.63 relaylock
12362 root 18 0 20196 1492 1212 R 6 0.1 3:00.41 authpsa
890 root 18 0 20200 1488 1212 D 6 0.1 15:13.27 authpsa
16890 root 18 0 18600 1092 924 D 6 0.1 1:41.20 relaylock
25035 root 18 0 18596 1092 924 R 5 0.1 0:39.16 relaylock
18417 root 18 0 20200 1492 1212 D 5 0.1 1:36.35 authpsa
19043 root 18 0 18596 1088 924 D 5 0.1 1:25.29 relaylock

When I killall relaylock & authpsa mail functions return to normal. Any suggestions?

While upgrading there was an error:

Trying to executing mail_restore to synchronize mail server settings and Plesk Database… Number of arguments is invalid.
Number of arguments is invalid.

Aug 22, 2009, 08:01 PM
Andrey Kucherov's Avatar

Andrey Kucherov
Member

Join: Apr 2009
Posts: 134

Hello,

You can use the following command to see if your Parallels Plesk Installation is uptodate:

Quote:
-bash-3.2# /usr/local/psa/bin/autoinstaller –select-release-current –show-components

Detecting installed product components.
base [up2date] – Base packages of Plesk
psa-autoinstaller [up2date] – Plesk Updater
php5 [up2date] – PHP5 support
postgresql [install] – PostgreSQL server support
vault [install] – Application vault packages
ppwse [install] – Plesk Professional Web Site Editor
api [up2date] – Plesk API [former Plesk Agent]
pmm-vz [upgrade] – Plesk migration manager
sb-publish [install] – SiteBuilder publishing support for Plesk
sbm [install] – SiteBuilder module migration suite
cf-support [install] – ColdFusion support for Plesk
miva [install] – MIVA Empresa support
billing [install] – Plesk billing
mod-bw [install] – Bandwidth Limiter For Apache support (mod_bw)
asp [upgrade] – Apache ASP support
java [install] – Tomcat Java Servlets support
mod_python [up2date] – Apache mod_python module
ruby [install] – Ruby on Rails support
qmail [install] – Qmail mailserver
postfix [up2date] – Postfix mailserver
psa-firewall [install] – Plesk Firewall module
psa-vpn [install] – Plesk VPN module
psa-fileserver [install] – Plesk Fileserver module and SMB file server package
sshterm [up2date] – SSHTerm – SSH Terminal java applet
watchdog [install] – Watchdog (System monitoring module)
cs-gs [install] – Plesk Counter-Strike game server module
battlefield [install] – Plesk Battlefield 1942 game server module
bf2 [install] – Plesk Battlefield2 game server module
mailman [install] – Mailman mailing list manager support
kav [install] – Kaspersky antivirus module
drweb [install] – Dr. Web antivirus
spamassassin [install] – SpamAssassin support
backup-vz [upgrade] – Plesk Backup Manager
de-DE-locale [install] – German language pack
ja-JP-locale [install] – Japanese language pack
es-ES-locale [install] – Spanish language pack
ru-RU-locale [install] – Russian language pack
fr-FR-locale [install] – French language pack
it-IT-locale [install] – Italian language pack
zh-CN-locale [install] – Chinese language pack for China
zh-TW-locale [install] – Chinese language pack for Taiwan
nl-NL-locale [install] – Dutch language pack for Netherlands
horde [install] – Horde webmail support
atmail [install] – AtMail webmail support

If you will see componenets with status “upgrade” that means they were not upgraded properly.

Then you can use the following command to perform upgrade manually:

-bash-3.2# /usr/local/psa/bin/autoinstaller –select-release-current –upgrade-installed-components

You can find more information about updating in the following article:

http://download1.parallels.com/Plesk…uide/18514.htm

Aug 22, 2009, 10:47 PM
xetic
Junior Member

Join: Aug 2008
Posts: 9

Added a shell script to crontab to kill all relaylock and authpsa every hour so machine doesn’t become unstable until I can get some insight on resolving this issue permanently. Any suggestions would be greatly appreciated.

Aug 23, 2009, 02:23 AM
xetic
Junior Member

Join: Aug 2008
Posts: 9

In regards to above mentioned solution:

# /usr/local/psa/bin/autoinstaller –select-release-current –show-components

Quote:
Detecting installed product components.
base [up2date] – Base packages of Plesk
psa-autoinstaller [up2date] – Plesk Updater
postgresql [up2date] – PostgreSQL server support
vault [up2date] – Application vault packages
ppwse [up2date] – Plesk Professional Web Site Editor
api [up2date] – Plesk API [former Plesk Agent]
pmm-ded [up2date] – Plesk migration manager
sb-publish [up2date] – SiteBuilder publishing support for Plesk
sbm [up2date] – SiteBuilder module migration suite
cf-support [up2date] – ColdFusion support for Plesk
miva [up2date] – MIVA Empresa support
billing [up2date] – Plesk billing
mod-bw [up2date] – Bandwidth Limiter For Apache support (mod_bw)
asp [up2date] – Apache ASP support
java [up2date] – Tomcat Java Servlets support
mod_python [up2date] – Apache mod_python module
ruby [up2date] – Ruby on Rails support
php4 [install] – PHP4 support
php5 [up2date] – PHP5 support
qmail [up2date] – Qmail mailserver
postfix [install] – Postfix mailserver
psa-firewall [up2date] – Plesk Firewall module
psa-vpn [up2date] – Plesk VPN module
psa-fileserver [up2date] – Plesk Fileserver module and SMB file server package
sshterm [up2date] – SSHTerm – SSH Terminal java applet
watchdog [up2date] – Watchdog (System monitoring module)
cs-gs [up2date] – Plesk Counter-Strike game server module
battlefield [up2date] – Plesk Battlefield 1942 game server module
bf2 [up2date] – Plesk Battlefield2 game server module
mailman [up2date] – Mailman mailing list manager support
kav [up2date] – Kaspersky antivirus module
drweb [up2date] – Dr. Web antivirus
spamassassin [up2date] – SpamAssassin support
backup-ded [up2date] – Plesk Backup Manager
atis [up2date] – Acronis TrueImage module
de-DE-locale [up2date] – German language pack
ja-JP-locale [up2date] – Japanese language pack
es-ES-locale [up2date] – Spanish language pack
ru-RU-locale [up2date] – Russian language pack
fr-FR-locale [up2date] – French language pack
it-IT-locale [up2date] – Italian language pack
zh-CN-locale [up2date] – Chinese language pack for China
zh-TW-locale [up2date] – Chinese language pack for Taiwan
nl-NL-locale [up2date] – Dutch language pack for Netherlands
horde [up2date] – Horde webmail support
atmail [up2date] – AtMail webmail support

# /usr/local/psa/bin/autoinstaller –select-release-current –upgrade-installed-components

Quote:
Reading package lists…
Detecting installed product components.
You already have the latest version of product(s) and all selected components
installed. Installation will not continue.

Aug 27, 2009, 05:28 AM
Denis Sirochenko's Avatar

Denis Sirochenko
Senior Member

Join: Apr 2009
Posts: 246

Hello,

Please take a look at the following Knowledge Base articles:

[Info] Errors “database is locked” are shown in maillog. That cause them?
http://kb.parallels.com/en/6172

High CPU load on Parallels Plesk Panel server after upgrade to 9.2.1 and 9.2.2
http://kb.parallels.com/en/6345

Regards,
Denis.

Leave a Reply